Problème d'éclairage Hammer

  • Initiateur de la discussion
  • #1
Piickle Rick

Piickle Rick

Nouveau né
Messages
12
Score réaction
2
Points
20
Bonjour, je vous redemande de l'aide sur l'éclairage de ma map.

J'avais déjà eu un problème "Too many t-junctions to fix up! (3685 prims, max 32768 :: 65607 indices, max 65536) " du coup j'avais pris la première solution : -notjunc
Du coup sa marche j'arrive a la compil mais maintenant je n'est plus d'ombre, la lumière est au maximum sur toute ma map.

Mettre -notjunc peut créé des bugs graphique donc j'ai essayé d'installer Propper avec SDK source mais lors de la création du mod, je ne peux pas sélectionner "Modify Half Life 2 singleplayer"

J'ai cherché pendant plusieurs heures une solution mais je n'est pas trouvé.

Voila le log : https://pastebin.com/PQE0TNmR

Merci pour votre aide.

Avant :

Entraide serveur de jeu - mTxServ - Problème d'éclairage Hammer - capture-decran-199-png.12626



Après :

Entraide serveur de jeu - mTxServ - Problème d'éclairage Hammer - capture-decran-200-png.12625


J'ai réussi a le faire sans -notjunc et le même résultat.
Mon hammer crash avant la fin de la compil mais le fichier est quand même créé, peut être qu'il y'a un rapport.
 
Dernière édition:
Pelisma

Pelisma

Geek suprême
Messages
271
Score réaction
59
Points
100
Tu a peut-être désactiver les lights
 
Dernière édition:
  • Initiateur de la discussion
  • #3
Piickle Rick

Piickle Rick

Nouveau né
Messages
12
Score réaction
2
Points
20
J'ai supprimé le light_env même problème.

J'ai supprimé des light sa arrange rien. C'est un bug graphique je pense
 
Akulla

Akulla

Helpeur Divin
Messages
4 387
Score réaction
2 721
Points
550
Elle s'est juste pas compilé + sa a l'air d´etre Une décompilation
 
  • Initiateur de la discussion
  • #5
Piickle Rick

Piickle Rick

Nouveau né
Messages
12
Score réaction
2
Points
20
Quand je la compile hammer crash mais le fichier est quand même créé et je ne sais pas d'où viens le problème
 
Lap3che

Lap3che

Helpeur Divin
Messages
2 254
Score réaction
1 400
Points
445
Déjà sur la première ligne du log :
  1. materialPath: D:\Steam\steamapps\common\GarrysMod\garrysmod\materials
  2. Error opening c:\users\higui\desktop\rp_americanprison_v2d_dedit1.vmf: File c:\users\higui\desktop\rp_americanprison_v2d_dedit1.vmf, line 1: No such file or directory.
 
  • Initiateur de la discussion
  • #7
Piickle Rick

Piickle Rick

Nouveau né
Messages
12
Score réaction
2
Points
20
Je vais regarder sur Internet pour essayer de me débrouiller merci à vous
 
Lap3che

Lap3che

Helpeur Divin
Messages
2 254
Score réaction
1 400
Points
445
*Au cas où*


C’est juste qu’hammer ne trouve pas ton vmf quand il essaie de compiler
 
  • Initiateur de la discussion
  • #9
Piickle Rick

Piickle Rick

Nouveau né
Messages
12
Score réaction
2
Points
20
Mhh... Tu peux m'en dire plus ? Je mets simplement le vmf dans un dossier sur mon bureau. Je dois le mettre ailleurs ?
 
Lap3che

Lap3che

Helpeur Divin
Messages
2 254
Score réaction
1 400
Points
445
Piickle Rick à dit:
Mhh... Tu peux m'en dire plus ? Je mets simplement le vmf dans un dossier sur mon bureau. Je dois le mettre ailleurs ?
Généralement le vmf doit être rangé dans le dossier map de gmod
 
  • Initiateur de la discussion
  • #11
Piickle Rick

Piickle Rick

Nouveau né
Messages
12
Score réaction
2
Points
20
Merci pour ton aide, j'essaye sa de suite
 
  • Initiateur de la discussion
  • #12
Piickle Rick

Piickle Rick

Nouveau né
Messages
12
Score réaction
2
Points
20
Sa a réglé des problèmes mais toujours le problème d'éclairage et hammer qui crash.

Entraide serveur de jeu - mTxServ - Problème d'éclairage Hammer - capture-decran-205-png.12660


Voila le nouveau Log : https://pastebin.com/JZAkaNf1

Creating default LDR cubemaps for env_cubemap using skybox materials:
skybox/militia_hdr*.vmt
! Run buildcubemaps in the engine to get the correct cube maps.
Creating default HDR cubemaps for env_cubemap using skybox materials:
skybox/militia_hdr*.vmt
! Run buildcubemaps in the engine to get the correct cube maps.


FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (1378.0 7016.0 -6.5)


Je pense pas que sa sois normal sa non plus.

Encore merci.
 
Lap3che

Lap3che

Helpeur Divin
Messages
2 254
Score réaction
1 400
Points
445
Alors, pour commencer tu as un brush qui gêne la compilation, ici c’est le brush 16640, je te conseille d’aller voir ce qu’il a de spécial, et pourquoi il pose problème.
Ensuite tu as ÉNORMÉMENT de numportals, tu en as plus de 27000, ce qui est assez gros comme chiffre, donc je peux juste te conseiller d’optimiser un peu plus ta map, à coup de func_detail, et de propper.
 
  • Initiateur de la discussion
  • #14
Piickle Rick

Piickle Rick

Nouveau né
Messages
12
Score réaction
2
Points
20
Sa marche, j'ai supprimer les brush en cause, je vais optimisé tout sa. Merci
 
Haut